Geo Location Controls Degraded

Incident Report for JW Player

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 17:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results
Posted Mar 31, 2026 - 16:58 UTC

Investigating

Geo-location enforcement is currently degraded for Studio DRM customers using the Geo Location API and token geo settings. We are actively investigating.
Posted Mar 31, 2026 - 16:54 UTC
This incident affected: Studio DRM.